Showing results for 
Search instead for 
Did you mean: 

Wi-Fi Direct causing channel interference - how to disable?

Hi, I have a 3801UK NowTV stick running 8.1.3 firmware.

This device appears to be broadcasting a Wi-Fi direct SSID on the same 5Ghz channel as my router (even if i change the router wifi channel) and causing severe interference.

Ive tried looking in System - Advanced system settings, but there is no WiFi direct setting to disable, as another post suggested.

How can I disable this WiFi direct feature and stop it broadcasting? Its connected to a normal WPA2-PSK home network.



0 Thanks
1 Reply

Re: Wi-Fi Direct causing channel interference - how to disable?



I'm also looking for a way to disable the nameless WiFi-Direct network on a Now TV Smart Stick.


Like the poster above, I found this reference ("Solution" by Andy) to a way to disable it on the Now TV Box...


...but for the Now TV Stick there is no such option under: "Settings > System > Advanced System Settings > Device Connect"


There is a different but similar option in there, about allowing other devices (mobile apps) to connect/control the stick (Default, Permissive, Disabled), but setting that to Disabled &  restarting the stick didn't remove the WiFi Direct network.


Perhaps the remote control supplied with the stick uses WiFi Direct to communicate? And is this not the case with the Now TV Boxes? So perhaps by design it isn't possible to disable it on the stick?


Thanks for any help!

0 Thanks