cancel
Showing results for 
Search instead for 
Did you mean: 
Highlighted
Scholar

4K Smart Box - wifi booster issue with internet connection

I've had the new NowTV 4k Smart Box for a couple of weeks now with seemingly few problems.  It is linked via wifi to a Sky Q Router on standard Sky broadband (with a reliable 16Mb download speed).

No problems conecting through to NowTV until I tried adding my Sky wifi booster into the mix a couple of days ago.  Not that the wifi signal to the NowTV box was bad but I thought the booster might help a bit.  Unfortunately it seems to be causing problems in that I seem to be getting slow responses / picture freezing  / break-up.  Running a connection test on the NowTV box shows problems with the internet connection, but not all the time.  If I take the Sky wifi booster out the equation everything seems ok.  The booster has a positive impact on the signal strength (as atested to by my wifi signal on my phone) but seems to "confuse" the NowTV box.

Has anyone had the same issue?

I've tried resetting the Sky Q hub to factory settings (just in case) and re-linking the NowTV box to the wifi etc..  My internet speed is generally good and stable at about 16Mb.

I've got a TPLink booster but not sure if it's worth bothering if the NowTV box can't handle it.

0 Thanks
Reply
6 Replies
Highlighted
Legend 5
Legend 5

Re: 4K Smart Box - wifi booster issue with internet connection

Hi @SAABDude

Never used wifi boosters myself, so i doubt i will be much help here Smiley Sad

Are your TP WiFi boosters dual band or 2.4 ghz only ?

What happens if you go into the Sky Q Hub router settings using 192.168.0.1 using your internet browser and go into the wireless settings and rename the SSID by adding 2.4 G onto the 2.4ghz and 5G onto the 5ghz frequency band.

Then once you have re named both SSID, reset your wifi booster and go into the nowtv smart box settings under network and try both SSID freq bands on your home network to see if it makes any difference.

Worth a try, unless somebody on here comes up with a solution. 

 

Highlighted
NOW TV Team
NOW TV Team

Re: 4K Smart Box - wifi booster issue with internet connection

Morning @SAABDude

I'm using a TP Link at the moment. When I get home I'll try it with my NOW TV box.

I'll report back tomorrow Smiley Happy

Highlighted
Scholar

Re: 4K Smart Box - wifi booster issue with internet connection

Hi @schnapps

Thanks for the suggestion.  The TP Link booster is only 2.4Ghz , so not dual band.  I'm guessing the Sky booster is the same.

0 Thanks
Reply
Highlighted
Legend 5
Legend 5

Re: 4K Smart Box - wifi booster issue with internet connection

Hi @SAABDude

I have never used or have any experience with wifi boosters sorry, where my wifi coverage is excellent in my house and a lot of my devices are wired over Ethernet.

Unless @Graham-S comes up with any ideas about your TP link wifi boosters, if i was in your position i would jump over to the Sky Broadband Community and maybe type in TP link wifi booster in their website search engine to see what results it gives you, where they may be some setting need to be changed on the Sky Router.

0 Thanks
Reply
Highlighted
NOW TV Team
NOW TV Team

Re: 4K Smart Box - wifi booster issue with internet connection

@SAABDude I was unable to replicate the issue Smiley Sad

It works fine on my NOW TV box, but then again I have a different broadband provider so that may be a factor.

Like @schnapps said, pop over to the Sky forums to see. You can't be the only one having this issue.

0 Thanks
Reply
Highlighted
Observer

Re: 4K Smart Box - wifi booster issue with internet connection

Hi,

I am having the exact same issue as described above.

I have 2 X 4k boxes and if I'm watching live TV it's very glitchy or poor quality, not all the time, it comes and goes but very often, to a point it's not watchable! I never had this issue with my old nowtv boxes? I've tried them hard wired to the router, power line adaptors and my wirlesh mesh system, I've tried new hdmi cables, different HDMI ports, different TVs and it's the same.

Is there any other trouble shooting I can do? My broadband is with SSE I have 56mbs download and 10mbs upload.

Thoughts?

Thanks

0 Thanks
Reply