Showing results for 
Search instead for 
Did you mean: 
Anonymous User
Not applicable

Hub wireless channels

Hi all,


Never posted here before so hope I follow all rules correctly.


Signed up to Now TV broadband combo after BT got in touch and wanted a stupid amount of money for continuation of relatively poor service, so we cancelled, took out the Fab Fibre package, 40mbps, Entertainment thrown in, blah blah, all is well and good.


A few days in to the package and we are receiving terrible speeds, like, 2mbps between the two of us, not enough to basically do anything, I struggled even to load the router log in. I'm pretty savvy when it comes to technology, so logged in to the router to see which channel it had sat us on, it was 1, when I checked interference from nearby networks using Wireless Diagnostics on my MacBook, wandering through the flat, it turns out that 1 is by far the worst channel for it to sit on, 2, 6, or 13 are apparently the best.


I then painstakingly went through every channel at various times, checking download and upload speeds and ping, making sure which one was the best, channel 2 is the best for both of us, so why it always sits on 1 when I leave the setting to Auto I have no idea.


Now, our apartment building has a lot of wireless networks in it, my MacBook can see 11 just from me doing a scan, pretty much everyone sits on 1 or 6.


What I don't understand is the random drop outs we've had, of an evening, speeds can dip as low as 20kbps, and this is on the least congested channel. Generally throughout the day we get the high end of 20mbps or even as high as 35mbps on some days (13mbps right now, I always test through both and I obviously understand that evenings will slow things down, but the complete drop for seemingly no reason for around 4 minutes at a time to all devices, before the network recovers, baffles me, and it's at random times.


I've tried different channels, different times of day, nothing really seems to help, I'd just accepted that because it was a 2.4Ghz Hub in an apartment building, I probably just need to plug in my own 5Ghz router to the back of the Now TV Hub.


However, yesterday morning, both of us woke up with no wifi on our iPhones, I had wifi perfectly on my iPad, 23mbps, but no signal to my flatmate's MacBook, and no signal to her iPhone either. My Apple TV was connected but not my Fire TV Stick, go figure.


Power cycled all devices, restarted iPhone twice, toggled on and off wifi on all devices, nothing, all this time my iPad is still working beautifully on wifi. 


As a last ditch resort, restarted the Hub, lo and behold, four minutes later, everything's working.


So, is this just ongoing interference, or is there an actual issue with our router? I'm starting to think it may be the latter due to it's inability to find the least congested wireless channel, random drop outs for a few minutes at a time, and now this inability for some devies to connect without a restart of the Hub.


Can anyone enlighten me?


I'll paste my last of broadband download speeds at various channels below from my own research.


Many thanks.


1 - 1mbps

2 - 20mbps

3 - 15mbps (variable)

4 - 13mbps (variable)

5 - 15mbps (variable)

6 - 13mbps

7 - 9mbps (variable)

8 - 2mbps

9 - 1mbps

10 - 2mbps

11 - 1mbps

12 - highs of 27mbps, hovers around 7mbps most of the time

13 - 24mbps

Legend 5
Legend 5

@Anonymous User


Welcome to the forum. 


Firstly might be worth just checking speeds are fine at your Hub. 


Log into your router from a browser at (username and password is admin and nowtv unless changed) then go to the Maintenance tab. Here you can see the upload and download connection at the router. 


If these look OK it's probably not an issue with the line and like you say looks like an issue with wifi performance instead. 


If you live in an apartment building with lots of other wifi networks then you may well have difficulty on the 2.4GHz band that the Hub operates on - if you do have an old WAP or router you can daisychain in to provide your wifi then that might be a good option to go for, particularly as the Hub is a rebranded Sky SR102 router which doesn't have great wifi performance.


If you need to stick with the Hub then if most wifi networks close to you are on 1 or 6 personally I'd be going for channel 11 as that's the only other non-overlapping channel, but looking at your stats there may be a close wifi channel on that as well, try 12. Channel 2 looks good according to your stats but that's interfering with other wifi networks on both 1 and 6. 


You might also need to experiment with placement of the hub, generally speaking you want it as central, as high up and as far away from electrical interference, metal obstructions and solid walls as possible. Trying to use Ethernet as much as practically possible might also help. 





Anonymous User
Not applicable


Hub reports the following:

Line Rate - Upstream (Kbps):9995
Line Rate - Downstream (Kbps):39998
So that rather solves that, I've also done a line test from my account in Now TV and it told me I'm getting 40mbps download.
I do have an old 5Ghz Netgear router which the parents used to use when I still lived at home, before they got their Virgin Media Hub and they just had a simple modem, next time I'm home visiting, I'll bring it back and try it out.
Are there any instructions anywhere on how to disable the wireless in the Hub and use your own router?
I did try channel 13 briefly, but that works fine for me but not for my flatmate (she's at the other end of the hallway), so I assume there's something overlapping at her end of the flat. I'll try 12 sometime.
It's currently on a shelf by itself, middle of the flat in the hallway, nothing else plugged in next to it at all. 
Thanks so much for all your help!
Legend 5
Legend 5

@Anonymous User


The following should be about right for setting up the old router as your WAP


You can allocate it a fixed IP by your Hub from Advanced > LAN IP Setup. I wouldn't turn off wireless on the hub until you've got everything setup and made sure it's working, but when you do want to turn wireless off on the Hub it can be done from the Wireless screen. If you do this make sure you've got a laptop/desktop which you can connect to the Hub via Ethernet to get access to the Hub.

Anonymous User
Not applicable

I’ll give it a go, travelling up in the next couple of weeks for a visit so will give it a try then. Thanks!

Anonymous User
Not applicable

not only one, the wifi in these hubs is the worse ive ever seen, ive been up and down channels with speed test and not one gets into double figures, since having nowtv fibre its been non stop hell, i for one will be telling where to put this crappy router nest month. and for record ive never had any issues in past from other providers only nowtv, thats what you get using 2nd rate old sky routers