cancel
Showing results for 
Search instead for 
Did you mean: 
Anonymous User
Not applicable

Box not working properly

Hi, I have two of the nowtv white boxes. Both were working fine until recently, however one of the boxes is now playing up.

The box that is playing up started to do so after it received the update that introduced the new ' watch list'. The box crashed almost immediately after that update but unplugging it seemed to bring it back to life. However ever since then the box is extremely slow and sluggish and takes a long time to react to commands from the remote. It often freezes and shows nothing but a black screen or a black screen with the coloured circles.. But the circles are frozen and not spinning. Live channels in most seem to stream ok but moving around the interface and menus is very sluggish and this appears to get worse the more I move around until it just freezes/crashes completely. I can press for example the up arrow to move up a menu and sometimes wait a good 30 seconds before the box responds. I also noticed tgat the now and next for live channels is very often hours behind the actual time, although the clock is showing the correct time.

It is not just the nowtv app either, bbc, itv, demand 4 and most other apps are experiencing the same. Vevo seems to be the only one working without issue.

Also, since I unplugged the box, demand 5 has vanished..it was installed but has gone from the homepage and is not showing in the app list either and I have two bbciplayers, one of which does nothing and can not be removed.

I also had an issue where the box kicked me out of my account on nowt .. Giving a error saying that an error occurred. Login details were correct but it would just not accept them, whilst my second box had no problem.

I've reset the box and unplugged it multiple times now just so I can use it between these crashes, just glad I have a second box which I've had to take out of another room in the house now to use instead.

Is this a known problem and is the box faulty and needs replacing or is it something that can be fixed in some way? I'm at a loss as I cant understand why one box is fine and one started to play up after the watch list update.. If that I in fact what caused it.
0 Thanks
Reply
1 Solution

Accepted Solutions
Highlighted
Rich-L
Mentor 1

Re: Box not working properly

Hi @Anonymous User,

 

Thank you for getting back to us with that detailed information.

 

I'm sending you an email about this so please keep a look out for it.

 

Thanks,

 

Rich

The NOW TV Team

10 Replies
Community Manager
Community Manager

Re: Box not working properly

Hi @Anonymous User,

 

Thanks for posting.

 

That is quite odd that this is happening on just the one box and since the update.  Can we ask you to try these steps to override the current install of the update as it sounds like it might be corrupt.

 

Thanks

 

Simon

NOW TV Team

0 Thanks
Reply
Anonymous User
Not applicable

Re: Box not working properly

Hi @simon-J

I have tried what you suggested, the box downloaded and installed the update fine and restarted. Then the box was ok for about 30 mins, fast and responsive but has now gone back to being slow and sluggish.

It seems the longer I'm using it the slower it gets until it just stops working and I'm forced to unplug it to get it working again.

It is very obvious when its slow and its not the network im sure because for one it is only effecting one box and nowtv app on laptop works fine too and second you can tell by the remote it is slow because when i press a button on remote it takes ages to respond to it and the beep it makes takes ages to sound and acknowledge the button was pressed.

Its actually got worse since I posted, on two occasions it lost sound and I had to unplug it to get the sound back. It has also started to jitter the picture sometimes when on a fast moving screen or where alot of action Is going on but that only starts if the box has been in use for around half hour.

I did notice something else too but I don't know if its normal but it was really warm. I checked my other box which has been in use all day and that is barely warm at all. Both are not in cabinets, they just sit on the top of the stand so ventilation isn't an issue.
0 Thanks
Reply
Highlighted
Rich-L
Mentor 1

Re: Box not working properly

Hi @Anonymous User,

 

Thank you for getting back to us with that detailed information.

 

I'm sending you an email about this so please keep a look out for it.

 

Thanks,

 

Rich

The NOW TV Team

Anonymous User
Not applicable

Re: Box not working properly

Thanks @Rich-L

I have received and responded to your email and provided some new info on the issue.
0 Thanks
Reply
Anonymous User
Not applicable

Re: Box not working properly

I just wanted to say a big thank you @Rich-L for the solution offered via email. Everything is perfect now, well more than perfect actually, I can not believe the difference it has made. It is now better than it has ever been.
0 Thanks
Reply
zendiver
First Poster

Re: Box not working properly

I think I have the same issue with my box. It is very slow to respond to the remote. Could you post the solution to this thread so that others who also have this problem can see what to do?

0 Thanks
Reply
Anonymous User
Not applicable

Re: Box not working properly

@zendiver

In my case the box was considered faulty and replaced so unfortunately I cant offer any further advise as to what you can do other than try a hard reset if you have not done one yet. In my experience, the white boxes just can not handle the demand of service anymore, they simply are not powerful enough and all mine have failed due to this.
0 Thanks
Reply
Community Manager
Community Manager

Re: Box not working properly

Hi @zendiver,

 

Although you've mentioned you seem to be having the same issue as @Anonymous User mentioned would you be able to outline what's happening and when so we can help you better?

 

Thanks

 

Simon

NOW TV Team

0 Thanks
Reply
Rosie6
First Poster

Re: Box not working properly

My box hasn’t started to respond very slowly to the remote. Only a few months old so not sure what can be wrong. It took 5 mins just to go down the channels to select a music channel. Very frustrating
0 Thanks
Reply