cancel
Showing results for 
Search instead for 
Did you mean: 
Anonymous User
Not applicable

blank screen

Once I've set the TV to HDM1 the next step is pressing OK or Home on the NowTV remote and usually I get something on the screen but not today.  The screen remains blank. I've changed the batteries and the internet is working too.

1 Solution
schnapps
Legend 5
Legend 5


@Anonymous User wrote:

Once I've set the TV to HDM1 the next step is pressing OK or Home on the NowTV remote and usually I get something on the screen but not today.  The screen remains blank. I've changed the batteries and the internet is working too.


@Anonymous User
Just to get the ball rolling.
Any white light on the front of the NowTV box ?
If the screen is blank with nothing shown apart from the HDMI 1 shown the screen, maybe the HDMI cable has come loose on the back of the box or TV.

 

View solution in original post

18 Replies
Andy
Legend 5
Legend 5

@Anonymous User

 

Welcome to the forum.

 

Check to see if the white light on the front of the box is on (it should flash briefly when you press a button on the remote). 

 

If that seems ok, you often find powering down the box and TV, checking the HDMI cable at both ends and then powering everything back up solves it (the usual turn it off and back on again routine!) but if you still have trouble after that post back.

 

 

Anonymous User
Not applicable

Thank you Andy, switching off and on again did the trick

schnapps
Legend 5
Legend 5


@Anonymous User wrote:

Once I've set the TV to HDM1 the next step is pressing OK or Home on the NowTV remote and usually I get something on the screen but not today.  The screen remains blank. I've changed the batteries and the internet is working too.


@Anonymous User
Just to get the ball rolling.
Any white light on the front of the NowTV box ?
If the screen is blank with nothing shown apart from the HDMI 1 shown the screen, maybe the HDMI cable has come loose on the back of the box or TV.

 

Anonymous User
Not applicable

Thank you Schnapps for responding, checked cables and the powered off and on again and all ok now

Anonymous User
Not applicable

Please help me I've had it rebooting then reset it connected to internet now a blank screen 

 

Anonymous User
Not applicable

Have the same problem. Tried above solutions still nothing
schnapps
Legend 5
Legend 5


@Anonymous User wrote:
Have the same problem. Tried above solutions still nothing

@Anonymous User

 

Have you tried the hard factory reset, by pressing a pin into the small reset hole for 30 secs on the back of the box ?

 

It boots the box up from its first initial start and you would have to setup the box from scratch inc inserting your username, password etc.

 

Are you seeing a lighter cloudy colour in the centre of the screen ?

Anonymous User
Not applicable

Hi yeah I've tried that doesn't make a difference. And no just a black screen
schnapps
Legend 5
Legend 5


@Anonymous User wrote:
Hi yeah I've tried that doesn't make a difference. And no just a black screen

@Anonymous User

 

Is there any white light on the front of your box ?

 

If not check that the power cable is connected tight into the back of the box and also the power plug is in properly at the mains.

 

If the white light is permanently on or flashes , then try using a different HDMI cable (if you got a spare in the house) and also try plugging the HDMI cable connected to the box into a different HDMI port on your TV (if your TV has more than one port).

 

Also have you got another TV somewhere in the house to connect the NowTV box, only to prove that the box works on another TV set.

 

Before changing or swapping HDMI cables make sure both your TV and NowTV box is switched off at the mains.

 

Should you have no success with any of the above suggestions, then maybe you could have a faulty box and because its under a year old (assuming you have got the black style box) you may need to ask the shop or retailer to exchange it for a replacement.

Anonymous User
Not applicable

Nothing is coming up on my tv screen it looks like my tele is off but it isn't. When I reset the now tv box by pricking the back of it eventually the purple screen comes up, then it goes off again. Tried changing cables etc. etc. nothing happening. Any help please?

Andy
Legend 5
Legend 5

@Anonymous User

 

Welcome to the forum.

 

NOW TV have identified an issue causing this and have posted a message about it here

http://community.nowtv.com/t5/NOW-TV-Service-Status/Now-TV-box-issues-18-10-2016/m-p/403208

I'd suggest going to that post and clicking Topic Options>Subscribe (you need to be signed in to do this) and then you should get an email when there is an update.

 

For or anyone else reading this probably best not to do a reset of the box, just wait until the issue is fixed.

Anonymous User
Not applicable

thank you just worked the next day!

Anonymous User
Not applicable

I have tried all the above minus changing port as only one. Am sorting out a replacement now
Anonymous User
Not applicable

Turning on, I get a subdued white light on the front.

 

Then 'Roku' appears on the screen briefly - with the letters doing a mexican wave - then the ligth on the front goes bright, and the screen just goes blank and nothing else.

 

The remote doesn't trigger anything - the light on the front of the box doesn't respond to any remote pressing.

 

I've changed batteries in the remote to ones I know are fresh.

 

I've checked connections, and done a hard reset of the box via the hole on the back.

 

Anything else before I return the box as defective?

4268
Legend 5
Legend 5

@Anonymous User  with the Now box you get chattering teeth when you first plug in the box.    I personally woud return it as defective.  

Please take a moment to click thanks or marked as solution if this answered your question. I am a community contributor and pop on when I can.
Anonymous User
Not applicable

My now tv box isn't even a year old never had problems with it apart from the first installation. Today it's divided to stop working all together and just get a blank screen, can anyone suggest something? Tried the resset button and another tv! I'm lost
Anonymous User
Not applicable

See the post above yours. From what I could see yesterday, there was a massive problem that affected many users, myself included, but the link posted by Andy now no longer appears to work... So I dunno if it was fixed or what...

Andy
Legend 5
Legend 5

@Anonymous User @Anonymous User

 

The status post has been removed as the issue should be resolved now. However the advice in the post was for anyone still having trouble to contact NOW TV on the following page (you can choose either the email or live chat options).

 

http://help.nowtv.com/contact-us/Troubleshooting-NOW-TV-Box-and-Roku