Showing results for 
Search instead for 
Did you mean: 
Anonymous User
Not applicable

Vimeo App Login Not Working

The Vimeo App login on our 9-month old NOW TV stick isn't working. It says to enter the code at on a browser, but that always returns the message "Uh oh, something went wrong! It looks like we're missing some required info, or the info you submitted was invalid. If you go back to the previous page and try again, it may work. If you receive this message again, please contact the app developer." I've tried repeatedly, after reboots, and using Firefox on both a desktop and a mobile.

Anyone know of a fix or workaround for this?



Legend 5
Legend 5

@Anonymous User 

Have you tried to delete and reinstall the app? 

Have you tried to unplug the router for a few minutes? 

When you say reboot, is this resetting the stick back to factory settings?

FYI that I do not work for NOW, just a NOW customer trying to help
Anonymous User
Not applicable

I've now tried deleting and reinstalling the app, but no joy.

And have just tried turning the router off for a bit. Again no joy.

By reboot, I meant I turned off the Now TV Stick and turned it back on a
few mins later. Resetting to factory settings and then setting it all up
again would be quite a hassle, and I think not a general fix for
software glitches.

Has anyone else got the Vimeo app working on a Now TV Stick?

Much appreciated.
Elite 3

@Anonymous User have you tried contacting the app developer as the error message suggests?


They also appear to be very active on social media and I found the attached screen grab on Twitter. Fyi, the NowTV Sticks are the same hardware as the Roku stick so it could be the same problem which by the latest comment on 26th Feb, still exists.


Anonymous User
Not applicable
@Saint1976 That was my next port of call, so have done that now. Thanks
for the extra info, though doesn't look optimisitic 😞  Will post back
here if/when I hear anything. Unless anyone else on here has a
workaround - am clutching at straws perhaps!!
Anonymous User
Not applicable

Well the reply from Vimeo is that (dropping the niceties and fluff 🙂 )
"The Vimeo TV app is supported on: Apple TV (4th generation devices and higher), Android TV version 5.0+, Amazon Fire TV devices, Chromecast (via our iOS and Android mobile apps). If your device does not fit these parameters then, unfortunately, it is not supported."

So although there's a Vimeo app available on NowTV/ Roku, some of which works, it looks like there's no plan to fix the bits that don't work 😞

Legend 5
Legend 5

The vimeo app for Roku/Roku-based devices is no longer officially supported . See the link below


Discontinued platforms


To be honest, this goes a long way to explaining some of the bizarre bugs I've noticed in the app over the past couple of years that never been fixed. The app been no longer officially supported is a shame as it is one of the few devices besides PC where subtitles are properly supported. It wouldn't be so bad if subtitles were supported on chromecast,  that they weren't the last time I checked

I do not work for Now . I am simply a Now customer trying to help I am a Community Contributor This means that I know a lot about the service. But just like you I am still a customer. This means I cannot help you with issues that would involve looking into your account directly. A member of the now TV forum team or live chat will need to assist you with these issues.