Showing results for 
Search instead for 
Did you mean: 

That didn't go to plan...

Getting fed up of trying to watch anything on now TV. 



70-80mps download speeds and good connection from BT internet. 


All systems and software up to date. 



Tried resetting everything.



It loads the adverts then stops to buffer and comes up with "that didn't go to plan..."



How do I resolve this issue?


Someone quick, before I lose my small mind and go insane. 

3 Replies
Legend 5
Legend 5


Try setting the stick back to factory settings.

Try using your phone as a hotspot.

Alternatively bin the stick and get an Amazon fire stick 🤣

FYI that I do not work for NOW, just a NOW customer trying to help

I'm with Sky Broadband with the same download speeds as you.

I have been getting the "that didn't go to plan" occasionally over the past few weeks. But on Tuesday, my internet disconnected for a few minutes and re-connected and since then I have had no end of problems trying to load any episodes. I would get "that didn't go to plan" even before the adverts would load or half way through the adverts like you, before playing the episode. Sometimes, I would get to watch the episode and then it would stop and give "that didn't go to plan" and I'd get stuck.

Live TV was fine however!

I have powered off my Now Smart Box numerous times and checked for updates, but it doesn't help.

Following the advice here:

The 1st step to power off the router for a few minutes and the Smart Box (again) has fixed it tonight (so far). I am positive that, given that the problem became persistent following an internet disconnect, and that rebooting the router has resolved it, that it has been a poor internet connection causing the issues for me.

Try powering off your router and Now streaming device for at least 5 minutes (the longer the better). Then plug your router back in, wait until it re-establishes an internet connection, then plug your Now device back in.


Sadly, powering off the router for a period of time, to get a new connection, was only a temporary fix. Today, the "that didn't go to plan" error is persistently back, as before, when trying to watch episodes.

So I contacted Now support and they are aware of this issue and are working on it, the representative said:

"we apologise for the technical issue that is happening on most NOW and supported devices. I assure you that our Support teams are engaged in resolving this matter on priority."

The representative took my device's details (version and serial numbers) and Internet provider because it will help them investigate. The representative said that they would be grateful if others experiencing the problem would also contact them so that they can gather the same information (I'm sure that the more information the better).

They will email me when it is resolved.

On another note, as my Now Smart Box wasn't working, I tried watching the same TV series on my PC (which I've used before), but I was encountering errors on that too, again, before loading the adverts. It was erroring with: "Oh no! Something's gone wrong" and the error code: SDK.BUFFERING_LIMIT.UNKNOWN_REASON.MAIN_CONTENT. I've reported that issue also. My PC is using a wired ethernet connection to the router, so it rules out wifi problems. The difference on my PC is that I could keep re-trying the content and it would load after a 2nd or at worse 3rd attempt, whereas on the Now Box, it would keep failing for me, no matter how many times I kept re-trying. I did find that if I left it 10 minutes and came back to re-try the Now Box, it would sometimes work to load an episode, but could then fail mid-way through play and crash. So for now, I'll stick to the PC to watch stuff as this seems more reliable for me.

In summary, it is clear that there are issues across different devices and it is not due to our internet connections, but the problem is at Now TV's end, which they are working to fix.

Bear with...