Showing results for 
Search instead for 
Did you mean: 

Smart Stick not working after update. Can't hard reset.

Hi all,


I bought a smart stick and upon setting it up it needed a system update so I started this.


I left it downloading/installing the update which was taking a while. When I came back later it was off. Assuming the update had completed and it had shut down I tried turning it on but the TV no longer seems to be recognising the HDMI.


The LED is on the stick and I have tried it on 2 other TVs with the same result. When trying to select the HDMI source it will either not show anything as available or will say there is no HDMI signal depending on the TV.


I have tried the TV USB port for power as well as a a USB Plug adapter. I have also tried holding down the reset button for 15 seconds to do a hard reset but I dont seem to be gettting any response.


Does anyone have any suggestions?





0 Thanks
3 Replies
Legend 5
Legend 5

Re: Smart Stick not working after update. Can't hard reset.

Hi @Jack1000 


Sounds like the system update has bricked the stick 😠.


If using the supplied power adapter there is a solid white light showing on the stick then there seems to be power on the stick.


Maybe try another HDMI port on your television (even though you said that you have tried the stick on two other TV's) and perhaps hold the reset button down longer when both the TV and stick is powered on in the correct HDMI input source on your television.


Other than that take or send the stick back to the Retailer you purchased it from and ask for a replacement or a full refund (unless anybody else on here has any other ideas to try).

Legend 5
Legend 5

Re: Smart Stick not working after update. Can't hard reset.

@schnapps @Jack1000 


If I recall correctly from the Stick I set up most recently, there is a reboot in the middle of the initial update process, and restarting the Stick in the middle of this is a no-no while it’s updating, and there is no way back.


Almost all devices are brickable by interrupting an update, or will self-brick if they hang during the update; it is the Achilles’ heel of such things.


My wife had a Moto 2 that bricked itself during an update, and was unsalvageable.


Fortunately, a user-bricked Stick is indistinguishable from a self-bricked or DOA one, so getting it replaced should be straightforward.


But next time, let the process run until the screen tells you it has completed, or until a couple of hours have elapsed, after which you can be pretty sure that it has self-bricked (again) this time.

If my posting answered your question, please click ‘Accept Answer’
(As long as you started the thread, and haven’t already accepted an answer)
If you liked my posting, please click ‘Thanks’ (the thumbs-up icon)
If you disagree with my posting, say so below, and I will see if I need to mend my ways 🙂

Re: Smart Stick not working after update. Can't hard reset.

Thank you for the swift response on this. I think all info points to it being bricked. 😞


Maybe it was just restarting when i thought it had shut down, howver it had been hours since i left it! I will try for a replacement.