Showing results for 
Search instead for 
Did you mean: 
Anonymous User
Not applicable

Remote stopped working after broadband dropped

I had a weird one today.

1) turned on TV early this morning. 20 seconds in the broadband dropped in the house the router was reset.

2) the remote stopped working and the stick seemed frozen.

3) The remote seemed to be making a high pitched sound. When I removed the batteries it stopped and started again when I put them back in. The battery test button got no response.

4) reset NOW TV stick several times no luck.

5) downloaded the remote control app and it worked fine 

6) remote still making high pitched noise.

7) replaced batteries - problem solved. Had to repair the remote but it's fine now.


The worrying thing is the original batteries were quite new and there were no warnings about low battery like normal. How on earth did a broadband drop cause remote control batteries to fail ?


It is also a huge coincidence that the broadband dropped 10 or 20 seconds after I started to use the NOW TV stick.


Any theories ? 


I had selected youtube and watched a 10 second video then it happened.

Legend 5
Legend 5

@Anonymous User 

Have you managed to use the stick ok since repairing the remote?


Maybe its worth putting in the old batteries again to see what happens?


How old is the Now TV stick? Did you purchase it directly from Now TV?

If you bought it from Now TV directly you might be able to get something sorted with staff. 

FYI that I do not work for NOW, just a NOW customer trying to help
Anonymous User
Not applicable

Hi @gavs82008 

The stick and remote is working perfectly now.


I will put the old batteries back in and see what happens.


I was more concerned about understanding how it happened and if I can prevent it happening again.


It seems very strange to me. 

Legend 5
Legend 5

Hi @Anonymous User 


I reckon it was a coincidence when you booted up your NowTV Stick when your internet went down.


Once you have no internet or the Router is still in the reboot process the NowTV Smart Remote will not respond to the Stick because it relies on WiFi (the only buttons on the remote that will work is the TV volume up & down plus TV standby button on the NowTV Smart Remote because these buttons work via infra red with your television).


The noise from the remote i haven't heard this before and my guess there is some sort of chemical chain reaction coming from your old batteries (especially once your WiFi settled back down and the new fresh batteries sorted out the problem).


I wouldn't recommend using cheap batteries with the NowTV or Roku Smart voice remotes, where from my experience once the battery level indicator is around 50 % charge left the remote gets unresponsive and temporary removing and re inserting the existing half used batteries work for a little while longer again.


With my NowTV & Roku Smart remotes i have stopped using cheap batteries from places like Poundland etc and use better quality batteries which also improves the time duration intervals the AA batteries need replacing.


Where with the cheap batteries i was using, i was replacing batteries every three to four weeks.


If you are using quality AA batteries with the NowTV Smart voice remote, then just ignore my last couple of paragraphs, but it might be useful information for forum members who use cheap batteries in their NowTV / Roku Smart voice remotes.



Legend 5
Legend 5

Hi @Anonymous User 


I should have said Router was down aka with no WiFi and not the internet, where the NowTV Smart Remote buttons should still respond by pressing them with WiFi still outputting on your Router and using the same WiFi network has your Stick.

Anonymous User
Not applicable

Hi @schnapps ,


Thanks for the reply. Just a note the entire remote stopped working even the volume buttons on the side and the button under the battery cover.


Regarding batteries I have found the same thing that cheap batteries are useless, I always use Duracell now and they generally last a few months. Was just weird there was no warning indicator this time, its almost like they short circuited themselves in the remote.


Anyway everything is fine now but I'll be on guard for anything strange like this happening again next time my remote becomes unresponsive or the broadband goes down.