Showing results for 
Search instead for 
Did you mean: 

NOW TV Boost, no 5.1



I've just started the trial of NOW TV Boost on the NOW TV stick. HD is being recognised but the Boost settings are not recognising 5.1 even though I have that set in the audio settings. 


I have tried signing out and switching off the stick but nothing works. 


Anyone got any ideas? 





Any help would be much appreciated, cheers. 

Anonymous User
Not applicable

Hi all. For 5.1 to work the NowTV boost settings must be set to either DolbyD+ or DolbyD+/DTS all other settings result in Stereo only. Sonos Beam does not work with DolbyD+ so will not output 5.1 with a NowTV box or stick. Hopefully a future firmware update will let the DolbyD setting work which would then work with Sonos Beam. 

View solution in original post

Anonymous User
Not applicable
I believe the HDMI sound only goes back to the amp if you are using the ARC port on your Samsung TV (HDMI port 2 on mine) but I have all my devices plugged directly into the amp. It would be worth plugging the NowTV stick directly into the amp to see if that helps.
Anonymous User
Not applicable

Have now tried with all sticks connected to Yamaha receiver, and you are right my receiver is also connected to the Samsung by ARC - HDMI 2 on TV. So now Sky+ box, Blu ray player, Firestick and Nowtv stick all go into receiver and then on to TV, all by HDMI leads, but 5.1 still not coming from Nowtv stick. If I set Nowtv stick to DD+ (as suggested in other posts) I get no audio so need to have it set at DD. Amazon Firestick working perfectly though, HD and 5.1. Still think it is a setting in Nowtv stick not correct, but which one I do not know, any more thoughts out there I can try ?

Anonymous User
Not applicable

well, i'd read this entire thread (if you havent) as there are other people with the stick (i have the app on ps4) .


Make sure your reciever is set to auto decode? (Probs not that, i agree its nowtv related probs)


(For the ps4 app) i can browse to 

1) My account

2) Nowtv boost (settings)

3) can then select either stereo or surround sound. (Obvs choose the latter)


I dont get options for DD or DD+

Anonymous User
Not applicable

@Anonymous User My mate has the stick, and had it working with the following settings: not sure how to browse to these pages but hopefully you can work it out


Audio mode - auto (Dolby D,DTS)

HDMI - (Dolby D,DTS)


HDMI options (looks like separate page)

Dolby D,DTS

Auto detect=yes 

Pcm stereo (maybe they mean a pcm bitstream here)


Hopefully that helps.


Tried Now TV on my BT YouView box and 5.1 works perfectly. Same setup. 100% sure they changed something on the PS4 app now 🙂 

Anonymous User
Not applicable

Hi @Anonymous User, i dont have the stick.. only the app. But your setup sounds like youre using HDMI ARC (audio return channel) and sending 5.1 from tv to reciever. Unless you have 2020 devices that support eARC (enhanced audio return channel) then it only supports audio up to 5.1, and therefore excludes DD + and atmos (the newer sound formats). Maybe try using a ps4 or blu ray player plugged into reciever and then into tv as a test and see if it works? But of a hassle to reconnect i know, but you would isolate the problem at least.

The solution would be to use this config or to buy kit and hdmi that supports eARC.


Hope thst helps anyway.

Anonymous User
Not applicable



The solution for me (after much searching, hair pulling and cancelling my Boost pass in frustration) was:

•Make sure you have the surround sound set in the OS

e.g. Audio Mode = (Auto (Dolby D+, DTS))

•Play a video in your NowTV app.
•Press the * key on your remote.

•Change the “Volume Mode” to off.

•Restart the NowTV / Roku device.


It looks like the volume levelling in the app prevents the Surround Sound feature from working in the NowTV app. My Pioneer VSX-933 amp is now seeing input from “Dolby Audio - DD+ 5.1 ch 48kHz”. I hope it works for you.


THIS IS THE ANSWER HERE!!! Thank you @Anonymous User 


For anyone experiencing their stick or box not coming out of STEREO setting despite everything else being set to SURROUND.


The 'NIGHT' and 'LEVELLING' settings on the audio under the asterisk * menu OVERRIDE everything else on the APP and HARDWARE settings and downmix to STEREO as a result.


..... aaaaand RELAX!




Legend 5
Legend 5

Following up from my previous posts on this thread, where i couldn't get no sound on certain Audio settings via my NowTV box on my soundbase.


It looks like now that i can select Dolby Digital on my NowTV box and get full sound through my soundbase where previously when using the Dolby Digital setting i was getting no sound whatsoever.


When going to the My Account section of the NowTV App on the box  under the Boost Pass it doesn't give any indication anymore if you are in stereo or 5.1 surround sound and just refers you to the playback device Audio settings.


So it seems like NowTV have altered something since the last time i checked back in December.

Anonymous User
Not applicable

I’m replying to an old thread but the steps listed here sorted my no 5.1 sound issue -Thank you.


I have posted my own “solved” thread whereby I managed to get 5.1 working using various steps, however, my success was short lived when mysystem dropped back to stereo for no apparent reason.


 Watching films late at night prompted me to set “night mode” using the * button and as JamesM has identified, this subsequently screws up the output of 5.1 Dolby.


Serious bug in the system. 


Many Thanks  to JamesM for identifying this.




Anonymous User
Not applicable

I had to go into Boost settings in My Account within the NOW TV app on my PS4 And select surroundsound within the audio option. For some reason it had switched off.