Showing results for 
Search instead for 
Did you mean: 
Anonymous User
Not applicable

Low power message even tho plugged in mains

My now tv stick is showing the low power message and symbol even though it is plugged into the mains electric not tv. We are using the supplied plug but still won't come on saying low power

Legend 5
Legend 5

Hi @Anonymous User

If any of your TV's have a USB port on them rated at 900ma /0,9a then test the NOW Stick on them.

I would also try a different USB standard to USB micro cable if you have one around the house and maybe a 5VDC 1A or higher amp USB charger to see if the Stick low power message disappears. 

Anonymous User
Not applicable

the problem is the tv's usb is only there to power low powered devices like usb stick etc

Legend 5
Legend 5

@Anonymous User 

To follow up from @schnapps and @Anonymous User what happens if you do a factory reset to the stick?

FYI that I do not work for NOW, just a NOW customer trying to help
Anonymous User
Not applicable

Thank you for your help I am new to this and just learning how to reply





@Anonymous User 

I’m with @gavs82008 on this one.

If the stick says Low Power even when run with the supplied charger, then the charger, the cable, or the stick is faulty (assuming your mains hasn’t dropped to 180V, as happened to a work colleague of mine!).

So do a reset (with the stick plugged in and powered on, hold the little button on the side of it in for just over 15 seconds) and try it again.

If still no go, then try any any other USB charger you may have, with a USB Mini-connector cable for an Android device (they are all interchangeable), to eliminate these components from the problem.

If you still get the ‘Low Power’ message, then the stick is faulty 😢

But one of the above will hopefully fix it.

Set a Payment PIN on your account so that no-one but you can buy memberships on it.
Check your bank accounts monthly for any other unexpected payments to Now.
That way you can at least nip them in the bud, while you and Now figure out whose fault they are.