Showing results for 
Search instead for 
Did you mean: 
Anonymous User
Not applicable

HDCP Error (NowTV stick on a Panasonic TV)

This is driving us bonkers.


We have a Panasonic TV with a NowTV Stick, Playstation 3, Amazon Fire TV Stick (4k) all connected via HDMI. 


We are getting the HDCP error screen appear literally every time we fire up the NowTV Stick to watch NowTV or Netflix on a daily basis.


[EDIT - I have to add it had been working fine up until a couple on months ago and it has steadily seemingly go worse]


If I do the reset we get it working again but the very next time we use it the same error occurs. If we move the devices around between HDMI connections the same scenario works, then next time it doesn't.


It's only the NowTV stick that generates the error, the Firestick (WWE Network usage) and the PS3 continue to work fine. 


We do have a Humax TV recorder also attached via HDMI, is the NowTV stick suddenly aware of that and assuming it's doing something naughty (despite that only receiving a Freeview signal into it which is then "broadcast" to the TV via HDMI) ?


Am I missing something OR is there a chance the stick is going faulty ? It is getting rather hot during use and it was being powered via the TV's USB port. I reverted back to the mains adapter and I thought it fixed it....but no it was just like doing the connection reset 😞




This happens to me every now and then.  I turn the stick off and on again by removing the power.  And then it works. Also if you are using an external HDMI switch it can cause issues.  Put stick directly into HDMI port.

Anonymous User
Not applicable

That didn't work for us, was the 1st suggestion a Google search threw up. The issue continued every time we started using the stick.


We even turned off screensaver (another found suggestion) with no joy. Also moved from USB power to the mains adapter with no joy. 


What did work was giving up totally and going back to an old black NOWTV box. No repeat of the HDCP error since doing that. It's a bit slower but it's far less stressful. 


So I'd guess either the stick (it was getting very hot) was faulty (maybe USB power did something) or the software powering it had an unrecoverable security glitch. Either way the stick is no more, long live the black box!