Showing results for 
Search instead for 
Did you mean: 
Anonymous User
Not applicable

problem with microsoft silverlight using Apple iMac

Hello to all at NOW TV, Please can you help? Everthing was working fine until last night. And then for some strange reason I can't access and watch any movies and/or programmes due to problems with microsoft silverlight. I've tried every solution in the help section and on the forum to no avail. I'm prompted with this message as shown below: 


Sorry, you’re not quite ready yet...
You need to install or update Microsoft® Silverlight™ to watch NOW TV.

After installation, refresh this page or restart your web browser.


87 Replies
Anonymous User
Not applicable

Woohoo it's alive ..alive!!

Anonymous User
Not applicable

yes I also have same problem, please sort ASAP NOW TV  thank you 


Hardware Overview:


  Model Name: iMac

  Model Identifier: iMac9,1

  Processor Name: Intel Core 2 Duo

  Processor Speed: 2.66 GHz

  Number of Processors: 1

  Total Number of Cores: 2

  L2 Cache: 6 MB

  Memory: 8 GB

  Bus Speed: 1.07 GHz

  Boot ROM Version: IM91.008D.B08

  SMC Version (system): 1.37f3

  Serial Number (system): VM912HFK0TJ

  Hardware UUID: C11389FA-8640-5F61-9A5F-FE2192A4360C

Anonymous User
Not applicable

Hi @Anonymous User


Thanks for getting in touch with us 🙂


Could you confirm if you've tried the steps tried by @Anonymous User?


Could you try these if on Safari 10 or above?


  • Go to
  • Open something ready to try and watch (make sure the URL says not just
  • Go to the top menu and click Safari then choose Preferences
  • Choose "security” with the padlock icon
  • Click “plug-in settings”
  • Choose “Silverlight” from the list on the left and tick it
  • It should now say “currently open websites” and the customer should see “” click the drop down box next to this and choose “on”
  • Click Done

Please let us know how you get on and we'll be happy to help further.







Anonymous User
Not applicable

I'm trying to watch NowTV on Safari 10 on a brand new iMac running Sierra v10.12 and get the "problem accessing Sliverlight . . ."   I've done what the forum suggests but the Preferences plugin settings for Silverlight already included "" set to On.  I've also downloaded Firefox and tried that (although I shouldn't have to as Safari complies with all the required standards) but Firefox also returns a Silverlight problem and won't work.


I see this problem has been complained about for a very long time so I'm disappointed you haven't yet resolved it.