Showing results for 
Search instead for 
Did you mean: 
Anonymous User
Not applicable

Jumping audio and visual

I'm Watching a now TV live sport stream through the app on my LG smart TV. Initial viewing is fine but after 5-10 minutes the picture freezes, then the audio and picture go out of sink and the stream becomes 'jumpy' . I've ran a Speed test and I regularly get 45mb/s. when watching nowtv on other devices in the house the service is fine so it's not a speed or bandwidth problem. There are no updates needed on the TV. The problem only occurs when watching live sport, the movie and entertainment packages work fine.
5 Replies
Anonymous User
Not applicable

I have the same issue. I must be glutton for punishment as it is not the first time it has happened with a day pass.

I can't see how sky can charge so much for a sub standard service.

Ps I've checked my signal/settings etc- it's a now TV isssue
Anonymous User
Not applicable

@Anonymous User @Anonymous User


Hi Guys


Is this issue only happening when viewing sports?




Anonymous User
Not applicable

Yes only when viewing live sports.
Anonymous User
Not applicable


Always on sports- not an issue on movies and entertainment.
Legend 5
Legend 5

Hi all,


Could both of you please confirm the following: -

  • Are you an existing or brand new NOW TV subscriber?
  • If you are an existing subscriber, when did you start having issues?
  • What's your LG televisions 'Model/Type' number and 'Software Version' number?
    [Which can be found via: Support '?' -> Product/Service Info.]
  • What's your NOW TV 'app' version?
    [Which can be found by launching the NOW TV app then visiting: My Account and looking 'top right' of the screen...]
  • Have you tried your LG televisions 'Intialization of App' option (if available on your model)?
    [Which can be found via: Support '?' -> Initialization of App]
  • How is your LG television connected to the internet. Is it via a hard-wired or wireless (WiFi) ethernet connection?
  • Who is your ISP (Internet Service Provider)?
  • Are you running any form of VPN (Virtual Private Network)?
  • Have you tried re-booting your router (by disconnecting the power, waiting 30 seconds and reconnecting the power)?