cancel
Showing results for 
Search instead for 
Did you mean: 
RoyB
Legend 5
Legend 5

Incredible Experiences

Seeing from the JustWatch app that Incredibles 2 was available on NowTV, and having the requisite Movies Pass, we went looking for it on Wednesday evening, 17th April, at about 19:30, on our grey-faced NowTV Stick.

 

In Search, I pressed the mic button, and the Stick responded, so I said ‘Incredibles 2’. The Stick said its voice feature wasn’t really ready yet.

 

(Just tried it again, Friday 19th, 09:53, and this time it ‘worked’, but only showed the two movies below).

 

So I typed in ‘Incredible’ and got two responses. The Incredible Hulk, and Homeward Bound: The Incredible Journey. Neither of which was Incredibles 2, or even the first Incredibles film.

 

Went back and checked JustWatch on my iPad. Still showing NowTV as having Incredibles 2, plus it being on at cinemas, but that was all.

 

Tried the NowTV app on my iPad. Aha! there it was, Incredibles 2. So I went in... and all it would do was let me add it to my Watchlist. But not actually watch it Smiley Sad

 

OK, we said, giving up. What’s on live at the moment? And look what we found, choosing Watch Live - none other than The Incredibles 2, live right then on Sky Cinema Disney, with 9 minutes left... so we went in, just to see if it really was there. And got offered ‘Watch live’ or ‘Watch from the start’.

 

So we chose ‘Watch from the start’, it played perfectly, and we thoroughly enjoyed it.

 

And afterwards, we tried (text) Search again - and now both Incredibles movies came up in the Search results.

 

So, what gives here? A problem with having these results in the Search?  If so, this is still affecting the mic Search, though not the text Search.

 

Or is it that a new movie doesn’t appear in the Search until it has been shown live? (Which wouldn’t apply to the first Incredibles movie, so maybe that was put back only as a pair with the second one?)

 

But JustWatch knew, somehow, that NowTV had Incredibles 2, even though the NowTV Search wouldn’t return it.

 

So - strange way to run a streaming service? Or just a small glitch?

 

I do realise, of course, that this does not amount to a hill of beans compared with many of the other tales of woe here, some self-inflicted but many not, of which too many are going unanswered, despite the heroic efforts of the leet peer group of subscribers. And there’s always Chat, though my own experience with this bears out that it (a) doesn’t always understand, let alone answer, our questions and (b) usually shuts off just as we start making progress.

 

But where are the Mods, mopping up the unanswered queries? 

 

It couldn’t be that Sky don’t want NowTV to be too straightforward and streamlined, lest it cannibalise their main business, could it? Smiley Tongue

 

 

 

 


If my posting answered your question, please click ‘Accept Answer’ on it
(As long as you started the thread, and haven’t already accepted an answer)
If you liked my posting, please click ‘Thanks’ (the thumbs-up icon)
If you disagree with my posting, say so below, and I will see if I need to mend my ways 🙂

This post has been archived

This post has been kept only for reference, it may contain out-of-date or inaccurate infomation.

Labels (1)
0 Thanks
1 Reply
robert1997
Elite

Re: Incredible Experiences

@RoyB 

And you thought things could be bad sometimes on Youview Smiley LOL

 

As for this community, yes it does appear it has been left to users to help out fellow users. Thankfully there are a few knowledgable guys around only too willing to help out their fellow NowTV 'struggler', unlike the Youview community where there seems to be more people (present company excluded, you're one of the good guys) out to berate anyone posting any sort of dissent against 'their' platform Smiley Wink

This post has been archived

This post has been kept only for reference, it may contain out-of-date or inaccurate infomation.