Showing results for 
Search instead for 
Did you mean: 
Anonymous User
Not applicable

SOLVED - Xbox One up won't play or Download since 29/1/19

In my case turned out to be a router issue - unplugged Xbox from ethernet, connected via hotspot on iPhone (hence bypassing router) - reinstalled app. Now runs fine with ethernet plugged back in

Think my router has a problem with Microsoft- the clue was that I got the same download error when trying to install an app on my PC

I'm using BT Broadband via an ASUS RT-AC87U. But not updated firmware or changed settings prior to 29/1/19, when we all (see many threads below) started to get this problem. Unless BT Broadband have blacklisted MS as a dodgy domain ...

Anonymous User
Not applicable

Thanks! This worked for me. It seems to be an issue with downloading / updating the app. I hadn’t considered that it might be the router, due to the fact that all other apps were working fine.

seems like this is a BT / MS store issue with this app. Unusual. Wonder if it will reoccur once an update to the app is required again.


again thanks for the help.