cancel
Showing results for 
Search instead for 
Did you mean: 
Highlighted
nottaclue
Occasional Poster

Devices

Help me! 

I've been watching Now TV on the Xbox since we purchased it. No issue's until i go on there this evening and not only had it logged me out, but i cant watch anything because its not a registered device even though its on my registered devices! Actually starting to get annoyed with it. 

One other thing, i was watching Sharp Objects before that miraculously dissapeared AND it had no warning? I only had 2 episodes left. Could have cried Now TV. 

Labels (1)
3 Replies
Amutant
First Poster

Re: Devices

I have the exact same thing. And I don't have any spare swaps! I think there was an Xbox update recently, Do you think the OS update has bust the now tv registry?

nicktenick1
Occasional Poster

Re: Devices

I had same issue with XboxOne today. I recently swapped out from one device to another but the xbox comes up with a message saying I am over the quota for devices. I might try deleting and reinstalling the App on Xbox.

SnowmanHD
First Poster

Devices

Same here, been using the app fine for a long time (including last night) but today it had logged me out and when i signed back in it said I was over my allowed number of devices!?!

Power cycled my Xbox and nothing happened. Checked my devices on my account and it confirmed my Xbox was one of the registered ones. Luckily I had a device swap left so I deleted the existing Xbox one and then tried to watch Sky Sports through the app, and thankfully it worked.

But... i have lost my last swap now so if it happens again I'm screwed. Am afraid to turn it off now incase it happens again. I want my swap back on my account.

So if anyone at Now TV is reading this you should reimburse those of us that have lost our swaps due to this error and sort out the problem for those who don't have any left to remedy the glitch.

It's irrelevant if it's an Xbox (Microsoft) update problem or a Now TV app error. It's your service which we all pay good money for.

One unhappy customer.