Showing results for 
Search instead for 
Did you mean: 
Anonymous User
Not applicable

Cannot load content at this time.......

I have been very patient with this (over several months now) and to begin with I thought it was my own equipment and have followed all the advice on this forum about resetting the Apple TV, re-installing the unit (which messes up the registered devices for a month), resetting routers, WIFI etc etc.


But now this inconsistancy of the error message "cannot load content at this time" is just ridculous.   ALL LIVE TV is fine, no problems at all.  But one day the Catch UP TV will work without a hitch, then next day nothing will work.  I have tried a random selection of programmes over all the channels and all say the same thing.  How can it work one day and then not for 3 days and then work again for an afternoon and then not for another day..... what are you doing to your servers???


This is happening on both my Apple TV units.


I would try on my iPad but I have to wait another month to do that 😞


Please, please NOW TV, sort this out!!  it is just not a professional service if it is not consistant (or consitantly awful!)

Anonymous User
Not applicable

Hi @Anonymous User


Thanks for your post and welcome to the forum.  This may not be of much use, but I view NOW TV on a regular basis via Apple TV and have experienced no problems.  I'd suggest contacting Live Chat and registering your iPad to try & determine whether or not the issue is with your ATV, your wi fi or none.  Click on this link and hit the Contact Us box on the left of the page, this will take you to the Live Chat & Email options (8am - Midnight).


Hope this helpsSmiley Happy

Anonymous User
Not applicable

Thank you for your response - Everythign works fine on my Now TV box.  It also work fine on my iMAC.


But my 2 Apple TVs with the up to date software do not work.  As I mentioned - it will work one minute, say I am watching an episode of The Tunnel - I go to watch the next episode and that ERROR message appears and then I cannot watch anything (other than LIVE TV).


So it cannot be my newtork, my WIFI or Router.  It is something with the Apple TV (working through all of this network stuff).


I have seen earlier in some of the Forum posts that Now TV did have issues with Apple TV users..... is this still the same?